Forum: VirtualDJ Technical Support

For reporting any bug, questions or comment related to the latest version of VirtualDJ
(NOTE: VirtualDJ continuously updated, so many older topic on this forum are most probably already fixed in the current build)

If you need extended support, contact our Support Team.
Forum Guidelines  (*) The moderators hold the rights to remove, move or modify posts.
Topic: Sample volume reseting to 100% even with velocity disabled (RMX2)

Dieses Thema ist veraltet und kann veraltete oder falsche Informationen enthalten.

I have a Hercules RMX 2 and im running the latest addition of VDJ. I keep running into an issue where when I initiate a sample with the sample pad the volume always resets to 100%. I have a knob set up to control the volume of the sample (which works just fine) , but regardless at what volume it's set at as soon as I enable via the pad it goes to 100%. I have the velocity for the sample pad disabled so this is not my issue. Outside of this, I'm not sure where to look. Theirs no arguments in my action, and when i mouse click the sample the volume DOES stay at the correct volume. The pad action is verbatim of what the mouse click would do yet the volume will always go to 100%. I'm at a loss and my sample volume is overpowering my tracks which doesn't make for smooth mixing. Please someone help, thanks in advance. Let me know if any settings or configurations are needed to help troubleshoot this problem.

geposted Wed 20 Jul 16 @ 9:06 pm
djdadPRO InfinityDevelopment ManagerMember since 2005
Sampler Velocity is enabled by default when VirtualDJ starts. This can be disabled within the mapping.
Open VirtualDJ, goto Settings->CONTROLLERS tab and select the Hercules RMX2 from the top list.
Search for the Key SAMPLE_VELOCITY_DISABLE and change the assigned action from false to true.

Note though, that the Volume of the Samples will go back to 100% if the Sampler Bank is changed. If you wish to keep a certain volume level for some samples, you will need to use the Gain from the Sampler Editor, which is saved across sessions and Bank changes too.


geposted Thu 21 Jul 16 @ 7:56 am
djdad wrote :
Sampler Velocity is enabled by default when VirtualDJ starts. This can be disabled within the mapping.
Open VirtualDJ, goto Settings->CONTROLLERS tab and select the Hercules RMX2 from the top list.
Search for the Key SAMPLE_VELOCITY_DISABLE and change the assigned action from false to true.

Note though, that the Volume of the Samples will go back to 100% if the Sampler Bank is changed. If you wish to keep a certain volume level for some samples, you will need to use the Gain from the Sampler Editor, which is saved across sessions and Bank changes too.



Thanks DjDad, I had disabled it in tray agent and also inside the sample_velocity_disable set to true, for whatever reason this did NOT fix my issue. I looked further into it, and even with those settings, the Sample_Veolcity (or whatnot) had an action that was something along the lines of Sample_volume 1-4.. I erased all the actions for the velocity function and it finally fixed my issue. Appreciate the input. not sure why disabling them didn't override the action but glad i figured it out.

geposted Fri 22 Jul 16 @ 12:41 am
djdadPRO InfinityDevelopment ManagerMember since 2005
Hmm weird, if you find some time, please try the following..
- Starting with the factory default mapping selected from the Mappings list, set the key SAMPLE_VELOCITY_DISABLE to true (will automatically create a Custom Mapping).
- Close VirtualDJ and open the Hercules Control Panel.
- turn Off Sampler Velocity
- Close Hercules Control panel
- Start VirtualDJ and then close again
- Open Hercules Control Panel and see if the Velocity is turned off (it should)

With Sampler Velocity disabled, the keys assigned as sampler_volume x should never be offered, so even if those are assigned to control the Volume of the samples, they shouldnt do anything

Also, see if disabling Velocity (with true as action), the same behavior is present on both sides (decks)

geposted Fri 22 Jul 16 @ 1:43 am
djdad wrote :
Hmm weird, if you find some time, please try the following..
- Starting with the factory default mapping selected from the Mappings list, set the key SAMPLE_VELOCITY_DISABLE to true (will automatically create a Custom Mapping).
- Close VirtualDJ and open the Hercules Control Panel.
- turn Off Sampler Velocity
- Close Hercules Control panel
- Start VirtualDJ and then close again
- Open Hercules Control Panel and see if the Velocity is turned off (it should)


followed verbatim and in hercules control panel velocity was turned back ON

djdad wrote :

With Sampler Velocity disabled, the keys assigned as sampler_volume x should never be offered, so even if those are assigned to control the Volume of the samples, they shouldnt do anything


I see your statement and I can assure you that even assuring both are disabled in control panel and within VDJ i'm running into the issue.

djdad wrote :

Also, see if disabling Velocity (with true as action), the same behavior is present on both sides (decks)


The same behavior is present on both decks.


I do apologize for the late response. I ran the directions you suggested in this post multiple times and each time I run into the same initial issue. My only fix was to delete the sampler_volume x action for each sample_velocity. Thanks for the time and I hope my feedback was helpful.


geposted Fri 29 Jul 16 @ 5:13 am


(Alte Themen und Foren werden automatisch geschlossen)