Forum: VirtualDJ Technical Support

For reporting any bug, questions or comment related to the latest version of VirtualDJ
(NOTE: VirtualDJ continuously updated, so many older topic on this forum are most probably already fixed in the current build)

If you need extended support, contact our Support Team.
Forum Guidelines  (*) The moderators hold the rights to move or modify posts in order to keep the discussions clear or to facilitate the search.
Topic: WINDOWS 10 DOUBLE-CLICK to INSTANTLY PLAY SONG issue
***FIRST take note, Windows 10 has a KNOWN issue with unintentional mouse double-clicking. It is not a problem with Windows settings, nor with the mouse or touchpad - it is a well-documented problem with Windows 10 itself (reported by literally HUNDREDS of users).

Problem:
Right-clicking a song in the AUTOMIX list and selecting, LOAD ON DECK 1_2 produces a SECURITY dialogue window:

SECURITY
A song is already playing on this deck. Are you sure you want to stop it?



Apparently STOPPING a song in mid-play and immediately playing a new song is important enough for a CONFIRMATION.

But if you DOUBLE-CLICK with the left mouse button, NO DIALOGUE! It STOPS the current song and IMMEDIATELY plays the song you double-click. No warning and no confirmation.

I'd like to ask the VDJ community to support my request to also have this CONFIRMATION when double-clicking the left mouse button as well.

Or, as it is ALREADY available when you right-click and select LOAD ON DECK 1_2, there's no need to have it on the left mouse button at all.

It CANNOT be disabled! It is assigned to BOTH the right and left mouse functionality. Having it only on the right-mouse is enough.

It is a matter of USERS requesting features, so I am asking the VDJ community to request this be a feature of the right mouse button, and not BOTH the right and left mouse button, as it works better (safer) with the dialogue already in place for the right mouse button.

IMPORTANT NOTES: Windows 10 users have confirmed in very large numbers, that mice and touchpads are double and even triple-clicking when not intended. There is a known issue, however Microsoft has made no efforts to resolve the issue. There are literally hundreds of posts on the Microsoft support website about the same issue.

Also note that I have CHANGED the double-click mouse setting in the control panel, and it has absolutely no effect at all on double-clicking.The Windows settings only allow for MORE time to double-click, but even on the fastest setting it still double-clicks when not intending to do so.

I am requesting they REMOVE the double-click INSTANT PLAY!!! feature from the left mouse button, and leave it where it is, on the right-mouse context sensitive menu.

Would you support this small change?

***Virtual DJ response to my concern about double-clicking a song by accident causing it to IMMEDIATELY PLAY without any confirmation or warning:
---
This is by design and it was requested by many users in the past as an easy way to switch to a different song from the list during automix. What double click does is a "Mix_Now" action.
So you can't disable this, but you are the first user with this issue.
I would suggest to try another mouse as It sounds like your mouse or touchpad is not so accurate on clicks (may be a dfected switch).
Also i believe that you can adjust the time and sensitivity for double click on windows, and make it less easy to double click.

-----------------
Best Regards.
Virtualdj Support Team.
Posted 35 minutes ago
PhantomDeejay
PhantomDeejay
Country: GR
PRO Infinity

Senior staff
Member since 2007
Quote
First of all there's a dedicated forum for wishes.
Second, as Support Team said, this is a widely used shortcut (as it's easier to double click than right click, bring up the menu and select "mix now" from the avilable options) by a lot of users.
Therefore most users that use automix on a frequent basis would not agree with your request.
However, you're free to suggest anything you like.
Just use the correct forum the next time! :)

Thank you!

Posted 26 minutes ago
soundsxtreme
soundsxtreme
Country: CA
PRO Infinity

Member since 2012
Modify Quote
There is a known issue with Windows 10, whereby DOUBLE-CLICK features in a program is problematic.

Microsoft has not fixed the problem, and so I am asking YOU to help us with this serious problem!

Until there is another way to prevent or affect double-clicking with Windows 10, please DISABLE this 'feature' from the left mouse button. It already exists in the right mouse menu - it's not needed in both, and with this Windows 10 issue, it's SERIOUS!

To support my request, here is PROOF that double-clicking is a SERIOUS ISSUE with Windows 10 users. Here is a forum post of currently 46 pages with hundreds of users who have reported the double-click issue.

***Please help Windows 10 users! Microsoft has not, so our only hope is that you will do SOMETHING to prevent this IMMEDIATELY PLAY NOW from happening.

I don't know how many VDJ users have Windows 10. But I do know, and now you do as well, that this is a problem for almost all Windows 10 users.

https://answers.microsoft.com/en-us/insider/forum/insider_wintp-insider_devices/windows-10-mouse-has-started-double-clicking-on/324165d1-0cf9-4439-af1b-5b9f93db8550

geposted Mon 06 Feb 17 @ 2:42 pm
PachNPRO InfinityMember since 2009
Judging by a quick read through approx. 10 pages of the MS thread it appears that most users with that problem are using a Logitech Mouse or R.A.T mouse.

It is stated that the mice are double clicking, but a "debouncer" that was present in older drivers is not present in the current Win 10 drivers... So, it is not neccessarily a MS issue...

Are you using a Logitech mouse?

A users mentions a software that should fix the problem.
I believe it is this one, but I can't open the site due to company policies atm.

Google for: CNET Left mouse button fix

geposted Mon 06 Feb 17 @ 3:01 pm
I am using laptops with built-in touchpads. Both are Windows 10 computers, but different makes/models. The issue is with both. There are a lot of gamers with Logitech mice with the problem, however it stems from new mice and touch devices being much more sensitive. The dpi is up to hundreds time greater, and touch sensitivity much higher.

I consider the feature of double-clicking without any dialogue to be dangerous to begin with. After all, the right-mouse, Load on Deck_ has a SECURITY dialogue, so why doesn't the left mouse button?

It would be a simple fix for Windows 10 users. I can't swap out a touchpad and there's no way I can find to disable double click on Windows 10.

I'd be happy with ANY solution - disabling double-clicking, or keeping the INSTANT PLAY NOW on the right-mouse button menu instead of on BOTH left and right mouse buttons. Seems reasonable...

geposted Mon 06 Feb 17 @ 3:10 pm
Your touchpads should have their own drivers and control panel interface. May be worth checking those (possibly difficult to find) settings or see if there are updated touchpad drivers on your PC manufacturers website.

This is yet another reason to avoid windows 10 as it can change without warning and screw things up right royally.

geposted Mon 06 Feb 17 @ 3:19 pm

geposted Mon 06 Feb 17 @ 3:37 pm
AdionPRO InfinityCTOMember since 2006
For touchpads in general, the first thing I personally do is disable the 'tap to click' option, so that it doesn't click when you're just touching it with your finger, but only when actually clicking the touchpad. That saves a lot of accidental clicking as well. (And quite hard to do an accidental double-click like that with any touch pad that I've used so far)

geposted Mon 06 Feb 17 @ 5:09 pm
i have 2 windows 10 laptops and i use logitec mouses. i have no issues like this and ALSO double clicking a song simply loads it the next available empty deck.
So example

Deck 1 is playing a song. double click on a song. it loads on deck 2, now if deck 2 is playing at the same time with deck 1 and you double click on a song, it will load it to deck 3. if all decks are full and playing, it will simply not do anything....so i dont really understand this issue. even if your mouse or touchpad double clicks, it doesn't load on a deck where a song is playing...

geposted Tue 07 Feb 17 @ 4:50 am
PachNPRO InfinityMember since 2009
Try doubleclicking in the automix list while automix is playling ;)

geposted Tue 07 Feb 17 @ 10:59 am
Adion wrote :
For touchpads in general, the first thing I personally do is disable the 'tap to click' option..."


Good one! I'm going to disable this too.

Adion wrote :
".......And quite hard to do an accidental double-click like that with any touch pad that I've used so far"


My new laptop (with windows 10) almost double clicks when I'm hovering my finger above the touchpad... Used the notebook 6 times now? And 4 times I loaded several times by accident a song on a deck which was already loaded.


geposted Tue 07 Feb 17 @ 12:47 pm
PachN wrote :
Try doubleclicking in the automix list while automix is playling ;)


Ok double clicking while AUTOMIX is on does load the song but it doesn't cut it. It fades it in and out just like automix. I believe it is intended to be like this.
So what would be good for the OP is to have an option to set this the way each user wants.

-Double click while automix on->>> 1)automix now, 2) don't automix now.

Not bad idea to be added in the settings. I'm sure some users will jump on having this setting...

geposted Tue 07 Feb 17 @ 3:27 pm
Any update on this? I would be nice to be able to disable double-clicking in automix to mix to the next song.
Any way to circumvent this?

geposted Sun 04 Mar 18 @ 8:58 pm
I had this problems many times - sometimes because of my broken mouse (yesss: Logitech) - sometimes because of my nervous finger.
Please make this feature optional. There are so many options in settings, whould be easy to add this one and make some of your users very happy.

Thank you!




geposted Thu 27 Sep 18 @ 2:33 pm
Will this be implemented ? Accidental double clicks in AutoMix are a real killer...

geposted Fri 22 Mar 19 @ 1:00 pm
i'm going to guess you didn't read through the entire thread (from last year...) with the solutions and work arounds presented.

geposted Sat 23 Mar 19 @ 1:12 am
+1 on needing this as an option. I have now twice screwed up in live DJing by accidentally double-clicking a song in automix and it directly mixes the live deck to the track I double-clicked. Rather embarrassing. In my use case (which is not at all unusual), I need there to be no way to interrupt the live deck so easily. I realize this is not everyone's need, so an option is the simple answer that will solve it for everyone.

I don't want to hear anything more about broken mice, trackpads, drivers, or settings. This is all on me, the DJ, accidentally double-clicking when I didn't intend to. None of those suggestions help that.

So please, VDJ, add this as an option so I can stop looking incompetent in front of a bunch of people dancing to my music.

geposted Wed 12 Jun 19 @ 2:32 am