Forum: VirtualDJ Technical Support

For reporting any bug, questions or comment related to the latest version of VirtualDJ
(NOTE: VirtualDJ continuously updated, so many older topic on this forum are most probably already fixed in the current build)

If you need extended support, contact our Support Team.
Forum Guidelines  (*) The moderators hold the rights to move or modify posts in order to keep the discussions clear or to facilitate the search.
Topic: Unable to control 4 decks with the DDJ-SB3
Hello.
I recently purchased the Pioneer DDJ-SB3 control. I'm running it through VirtualDJ 8.2 and have all the recent updates.

I purchased the SB3 so i could use 4 decks. However I'm finding that using the default mapping for the SB3 I still cannot switch to decks 3 and 4.

Strangely, sometimes it works and pressing the deck select button on the controller lets me switch decks, and then for seemingly no reason stops working again.

I understand that the mapping may be in its early stages as it is a new controller. Has anyone else had this issue or something similar? Is it a bug in the system? I've had a go at mapping the deck select buttons myself but still no luck / may be doing it wrong.

any help would be much appreciated.

Thanks!

Jake

geposted Wed 25 Apr 18 @ 3:22 pm
djdadPRO InfinityDevelopment ManagerMember since 2005
Can't reproduce here.

What is the Build of your VirtualDJ ?
Are you using the factory default mapping ?

The DECK 1/3 and 2/4 buttons are assigned to toggle left/right decks, but their LEDs are hardware driven, so regardless to what those are assigned to, when using these buttons you should get the following behavior.
- The LED will toggle, meaning that if its Off and press the DECK button, its LED should turn on.
- Mixer controls should be automatically assigned to the selected deck, meaning that even if you dont see the deck changing on the skin, the Volume faders should be assigned to Deck 1 or Deck 3 depending on the status of the DECK LED.

If the above is not the case for you, then something is wrong with your unit or its connection/firmware/drivers.

I've seen strange things on MIDI controllers (miss-behaving), so i would try with a different USB cable and/or different USB port

geposted Wed 25 Apr 18 @ 6:01 pm
Also, what skin are you using? Not all skins have four decks. Some are two deck skins.

geposted Wed 25 Apr 18 @ 6:27 pm
Thanks,

I'm using Virtual DJ 8.2, b4276. and I'm running it on a mac running OS High Sierra. I'm using the 4 deck skin. I'm using the default factory mapping yes. As I mentioned I have tried mapping it myself, with no luck. What should the Deck 1/2/3/4 key be set to?

The LED's on the Deck 3/4 button do not toggle on or off when pressed. Currently they are off and pressing them does nothing. Similarly pressing them and then adjusting the volume control etc does not effect anything on the skin.

As I also mentioned the other day it worked perfect upon launch of VDJ. and then just stopped working.

I didn't think i'd have to download drivers for a mac? I have also updated the firmware on the controller.

Very frustrating, feel like I'm a setting away from resolving the issue!







geposted Wed 25 Apr 18 @ 10:33 pm
any help would be greatly appreciated, thanks!

geposted Sun 29 Apr 18 @ 9:43 pm
RazethPRO SubscriberMember since 2016
I'm also having this issue. Newly purchased ddj-sb3 and on MacOS 10.13.6 - MacBook Air (11-inch, Mid 2011) - VDJ v8.3 b4720.

Plugged directly in via provided usb cable, and stock settings. I can also sometimes change decks a few times then it completely locks out and doesn't let me change decks as if the button were unmapped. Very frustrating.

I noticed that if I manually select deck 3 as left, then press the deck 3 button on the controller, it changes it back to deck 1, however I still can't get back to deck 3 to control it in any way. Same with deck 2/4.

Any luck?

geposted Thu 17 Jan 19 @ 2:25 am
I have the same issue with the sb3.... 3 and 4 dont work and I use the 4 deck skin as well...

geposted Fri 18 Jan 19 @ 5:00 am
djdadPRO InfinityDevelopment ManagerMember since 2005
In the past, i tried to reproduce but couldnt, so hard to fix anything there. Will give another try and let u know.
It appears to be a Mac only issue.

geposted Fri 18 Jan 19 @ 3:22 pm