Forum: VirtualDJ 8.2 Technical Support

Use this forum to report any bug, questions or comment related to the latest version of VirtualDJ 8.2.
Forum Guidelines

(NOTE: VirtualDJ 8.2 is continuously updated, so many older topic on this forum are most probably already fixed in the current build)
Topic: Numark NS7 III. Not being recognized
I recently purchased the Numark Ns7iii. I plugged it into virtual Dj 8 and all worked well but my no sound from headphones. Ended up downloading new drivers and reinstalling VDJ software and now it won’t recognize my controller. I do have the pro subscription and my computer is more than capable to handle the controller. The computer itself recognizes it in the USB ports without any errors. Any help would be very much appreciated.

Posted Tue 05 Dec 17 @ 10:08 am
djdadPRO InfinityDevelopment ManagerMember since 2005
KevinHouck wrote :
Ended up downloading new drivers ..


What do you mean by "new" drivers ? There are 2 drivers that need to be installed (ASIO and the ones for the screens)
https://www.numark.com/product/ns7iii

After installing the drivers, you may need to restart your computer (mostly for the screens to work).

When you say its not recognized now, please explain ..
Nothing works on the unit , e..g. the Pitch fader doesnt change the BPM/Tempo ?
Do the screens operate ?





Posted Tue 05 Dec 17 @ 10:45 am
When first connected, one of the the drivers didn’t install correctly. That’s why I had downloaded and and updated the drivers. When I connect to the software nothing happens with the controller. At all, no screens, no faders, no platters moving, nothing. When I go into settings on vdj it says it is not recognized.

Posted Tue 05 Dec 17 @ 5:05 pm
djdadPRO InfinityDevelopment ManagerMember since 2005
KevinHouck wrote :
When first connected, one of the the drivers didn’t install correctly. .


That's the key of your issue. If its not properly installed as MIDI, then VirtualDJ (or any other software) will be able to use it. Its up to Windows to properly install the necessary driver.
If you have already tried different USB ports and different USB cables (you should if not), one other thing you could try is to clean the USB "History". Try this tool https://www.cherubicsoft.com/en/projects/usboblivion


Posted Tue 05 Dec 17 @ 5:24 pm
I tried all the above options you said and still nothing.
i even tried reinstalling the software once more and still the same results.

Posted Tue 05 Dec 17 @ 11:15 pm
DHoudePRO InfinityMember since 2009
I have an NS7 iii too and I have used it for a year with relatively no issue. Going to need some info though. Lets start with do you have Mac or PC? Looks like PC because of the X on settings, but not having used Mac I have no way to confim that.

Also, can you try to plug your controller USB in directly to the laptop and either leave your screens disconnected from the USB or plug them in separately and directly into another port on your PC. Wondering if you might have a bad USB jumper or screens.

Posted Wed 06 Dec 17 @ 2:25 am
djdadPRO InfinityDevelopment ManagerMember since 2005
Your issue is not related to VirtualDJ, so re-installing wont help.

Issue is from Windows that for some reason can not see the unit as MIDI. BTW, the drivers you downloaded and installed are for the screens and the ASIO, nothing to do with the generic Midi functionality.
Just to confirm that Windows cannot see the unit as MIDI, you can download MIDIOX (Google it) , select from Options-->Midi Devices and see if the NS7III is there and can be selected.

there could be tens of reasons why this happens.. my personal advise and experience on these matters, is that resetting/re-installing Windows will probably take less time than searching and trying all kind of things.

BTW, what Version /Build of Windows are you on ? (Right-click on Start-->system). Any chance you are on the latest 1709 ?

Posted Wed 06 Dec 17 @ 12:50 pm
DBL-CRXPRO SubscriberMember since 2018
I have new NS7III and I plugged it in and my screen works on my display for the controller and bought the pro monthly and no tables turning or working can I please get help

Posted 7 days ago @ 9:11 pm
Did you read this whole thread?

Posted 6 days ago @ 9:46 pm
djdadPRO InfinityDevelopment ManagerMember since 2005
DBL-CRX wrote :
..no tables turning or working


Please explain further. Is it just the motorized platters that dont spin ?
Other NS7III buttons and faders work ? E.g. if you move the pitch fader on the unit, does it move the pitch fader on the main skin ?


Posted 6 days ago @ 10:24 am
LSL50PRO SubscriberMember since 2012
When I first bought my NS7III the same/similar thing happened to me, all numark drivers installed beforehand etc. An hour later and still nothing.....but I remembered that the ns7iii is a serato machine so maybe if I installed serato it may work or at least recognise it. I did just that - but still nothing so I just left it all connected and waited and waited (half hour later) Vdj came up with new device detected (or something like that) and it installed left and right screens then the ns7iii soundcard and everything worked. It was only later on after reading the online manual that numark mentions to plug in and turn the ns7iii on before starting the software. So maybe installing serato as well helped or maybe it didn't - or all I had to do was turn on the machine first etc. All I know it's been working brilliantly ever since

Posted 6 days ago @ 11:44 am