Forum: VirtualDJ 8.2 Technical Support

Use this forum to report any bug, questions or comment related to the latest version of VirtualDJ 8.2.
Forum Guidelines

(NOTE: VirtualDJ 8.2 is continuously updated, so many older topic on this forum are most probably already fixed in the current build)
Topic: (Shift & Wheel_mode 'search' while_pressed) Problem for DDJ - SB2
Hi, i upgraded from VDJ 8 to VDJ 8.2 today, and the Function for searching the track isn't working properly while the track is playing, though it is when its not. The script thats bugged is on the SHIFT button script and is (shift & wheel_mode 'search' while_pressed) and is the default setting for my controller.

.

The bug consists of it triggering a goto command that jumps 4 beats instead of a smooth search command when the (shift & wheel_mode 'search' while_pressed) is used while playback of the selected track.

It triggers a normal 'search' command just as it would regularly when the (shift & wheel_mode 'search' while_pressed) is used while there is no playback of selected track.

This problem was not present in the VDJ 8 build and i was free to use my Shift Search Function without problem with both the track playing and not playing

HELP, so far i've found nothing online and soon my only choice will be to revert back to version 8.

WIN 10
VDJ 8.2
All drivers ect are up to date

Thank you very much

Posted Mon 01 Jan 18 @ 12:20 pm
Can anyone help?

Posted Mon 01 Jan 18 @ 7:41 pm
The team who create the mappings will be on holiday at the moment. They will reply soon.

Posted Mon 01 Jan 18 @ 8:42 pm
Awesome, Thanks for the heads up. This is Literally my only issue with the build and its a nightmare to have the search jumping 4 beats during playback instead of being smooth. It wrecks havoc on my on the fly beat batching when i have that track in my ear before bringing the fader up.

Posted Mon 01 Jan 18 @ 8:55 pm
Which build of 8.2 are you using.

Posted Tue 02 Jan 18 @ 3:30 am
Currently Build v8.2 b4032, i opted for the beta updates after i noticed the build directly before this (sorry i dont know the build number) had those bugs hoping it would fix it.

The Build i upgraded from was v8.0.2483

It is quite the problem. And also upon further investigation i have noticed that the JOG functions are acting funny as well. they bend the pitch will trying to just JOG on Jog_Out and if you have Vinyl_mode on they scratch...

Those scripts are Factory default as well.

Posted Tue 02 Jan 18 @ 5:34 am
If memory serves even in earlier builds of 8.2 the DDJ SB2 has these problems. I think back then i just was so rushed for time i rolled back to 8 because i had a show the next day. The issue saddens me and i would love to see these bugs fixed seeing as i absolutely love this software, its my go to program when i'm not playing on CDJs. Especially since the latest builds have been stepping the audio quality game up if a solution came about i would just die with joy.

Posted Tue 02 Jan 18 @ 5:37 am
AdionPRO InfinityCTOMember since 2006
I'm not sure I understand exactly what it is doing wrong.
I don't have the SB2 to test with, but tried mapping the same command to a key on another controller, and while pressing it the jog wheel can be used to search through the track. It does indeed do this by jumping 4 beats at a time, which has the advantage that the deck stays synchronized with any other decks.
No scratching or pitch bend was going on while shift was pressed.

I also tried wheel_mode "loop_out" instead, and with that there was also no pitch bend or scratching.

Are you sure this is with factory default mapping? In particular JOG_OUT, JOG_VINYL, JOG_CDJ and SHIFT_JOG should be mapped to "touchwheel"

Posted Tue 02 Jan 18 @ 2:05 pm
djdadPRO InfinityDevelopment ManagerMember since 2005
The OP is probably referred to the new behavior of the Jog Seek/Search mode while the track is playing. Indeed the behavior is changed to match the Pioneer CDJ standards, so when the track is playing it moves at 4 beat steps (skips a bar) instead 1 beat.

If this new behavior bothers you, you could map
SHIFT as just .. shift (delete the & etc part)
SHIFT_JOG_TOUCH as .. nothing
SHIFT_JOG as .. song_pos
but you may then experience the Jog remaining in Search mode if you release the SHIFT prior releasing Jog

Posted Tue 02 Jan 18 @ 3:42 pm
DJ DAD that is what i am talking about.

Matching cdj standards or not I absolutely hate it,

I play on cdjs sometimes too and this new function for the script doesnt do me any good seeing as I don't even track seek that way on cdjs.... we have rekord box planning and ques and on the Nexus2 we have a touch screen to jump where we need to go then jog into place. i really don't see how this will prepare anyone for CDJS but then again thats just my opinion i guess.

I'll try the other script but song_pos will act differently during playback... I'm honestly telling you that enforcing a script change like that hurt me. And I'll probably roll back to a pervious version, where I had no problems and i will refuse to upgrade until I'm presented a build that give the option of a smooth seek during playback and not it skipping 4 beats.

Posted Wed 03 Jan 18 @ 12:53 am
And on that note you guess should really release patch notes with details of things changing behaviors like that..

Posted Wed 03 Jan 18 @ 1:16 am
It's not often but sometimes mapping does get changed and catches people out. It's usually minor tweaks but they are never documented in the changelogs as far as I have seen.

Posted Wed 03 Jan 18 @ 1:20 am
kradcliffe wrote :
It's not often but sometimes mapping does get changed and catches people out. It's usually minor tweaks but they are never documented in the changelogs as far as I have seen.


i just feel like something like that should be. Its kind of important to give your customers all the information they need about the product.. lol

Posted Wed 03 Jan 18 @ 1:29 am
But then there are literally hundreds of bug fixes and changes between major versions, some are quite minor and only appear on the early release change logs and not the rolled up ones.

It's a pretty small thing that has affected you personally but there's not really a way of communicating minor mapping changes to everyone who owns a specific controller. It's only happened to me a couple of times in ten years and although it can be infuriating you need to look at the bigger picture and there is always a workaround.

Anyway, Babis has given you all you need above to change the mapping back to where it was so no need to go back to a previous version.

Posted Wed 03 Jan 18 @ 2:38 am
True, the only thing ive added is a MUTE while_pressed so it functions even more similarly to search. its just infuriating lol. or they could script search to have a modifier for the CDJ standard version and their old version i like xD

Posted Wed 03 Jan 18 @ 3:27 am
Either way i really really appreciate both of your help. Its helped me achieve a work around that is acceptable.

Much appreciated. <3

Posted Wed 03 Jan 18 @ 3:29 am