Forum: Old versions

Use this forum if you are still using an old version like VirtualDJ 7.


NOTE: VirtualDJ 7 is not maintained anymore.
Topic: vdj 7 with high sierra
it is compatible?

geposted Wed 24 Jan 18 @ 3:29 pm
It's not been updated for two years. VDJ 8 is the latest version, compatible with current operating systems and controllers.

Why would you still want to use outdated software?

geposted Wed 24 Jan 18 @ 5:24 pm