Forum: General Discussion

About VirtualDJ and DJing in general

If you need extended support, contact our Support Team.
Forum Guidelines  (*) The moderators hold the rights to move or modify posts in order to keep the discussions clear or to facilitate the search.
Topic: What's your favorite latency setting for the Denon MC6000MK2 Controller?
jberenyiPRO SubscriberMember since 2015
I'm using the provided Denon AISO drivers and need to know what the majority's favorite setting is? And has anyone tried the WASAPI driver successfully? I couldn't make it work without losing my headphone cue function. I had to set the rotating knob on the front to Master to hear anything. Thanks all.

geposted Sun 23 Sep 18 @ 2:12 pm
That is always: as low as possible without compromising the audio quality.
The lower latency, the more smooth response from your controller
But if you set it lower than your laptop can handle, you will get artifact and small pops in the audio
You should be able to get below 10ms on decent laptops

geposted Sun 23 Sep 18 @ 2:20 pm
The Denon ASIO drivers can be a nightmare. Just switch to WASAPI and that will cure your problems instantly.

geposted Sun 23 Sep 18 @ 4:14 pm
I agree, I could never get the ASIO drivers to last more than a few hours, before all hell broke loose on the MK1.

geposted Sun 23 Sep 18 @ 6:18 pm
jberenyiPRO SubscriberMember since 2015
kradcliffe wrote :
The Denon ASIO drivers can be a nightmare. Just switch to WASAPI and that will cure your problems instantly.


Could you please send me a snapshot of your setup screen? Every time I go WASAPI I lose cue function in my headphones for any assigned channel. I only get output if I rotate the pan knob to "MASTER". But no output when rotated to "CUE".

geposted Sun 23 Sep 18 @ 7:17 pm

geposted Sun 23 Sep 18 @ 7:25 pm
jberenyiPRO SubscriberMember since 2015
kradcliffe wrote :
Just follow this but select WASAPI instead of Denon ASIO

https://denondj.com/kb/article/1833


I tried that but I still get no output in the headphone in full "CUE" mode on the pan knob on front of the controller.

geposted Mon 24 Sep 18 @ 1:18 am
jberenyiPRO SubscriberMember since 2015
Can someone provide me a screenshot of their WASAPI settings? I'd like to see it before I return this unit to PSSL. If I can get it to work I may refrain sending it back. Right now I can't get the Denon driver's to stop choking intermittently due to latency issues. But in WASAPI mode it works great. BTW I have a Core I5 processor on the laptop and it only has one program on it...VDJ 8. It's dedicated for DJing.

geposted Mon 24 Sep 18 @ 1:21 am
when using WASAPI you must make sure windows is not using the controller as the default sound card or you may have issues..

just something to try

geposted Mon 24 Sep 18 @ 1:24 am
jberenyiPRO SubscriberMember since 2015
wickedmix wrote :
when using WAPSI you must make sure windows is not using the controller as the default sound card or you may have issues..

just something to try



Should I uninstall the Denon drivers then?

geposted Mon 24 Sep 18 @ 1:27 am
the ASIO drivers can be uninstalled if you wont use them but they have nothing to do with my previous comment.

in this image see how the realtek sound card has the green check setting it as default.

if your Denon has that then you could have issues, so set it to the built in sound of the laptop to be default.


geposted Mon 24 Sep 18 @ 1:31 am
ewitlesPRO InfinityMember since 2006
jberenyi wrote :
Can someone provide me a screenshot of their WASAPI settings? I'd like to see it before I return this unit to PSSL. If I can get it to work I may refrain sending it back. Right now I can't get the Denon driver's to stop choking intermittently due to latency issues. But in WASAPI mode it works great. BTW I have a Core I5 processor on the laptop and it only has one program on it...VDJ 8. It's dedicated for DJing.


please and thank you :)

geposted Mon 24 Sep 18 @ 1:53 am
AdionPRO InfinityCTOMember since 2006
Also make sure that the speaker settings in windows are set to 4 speakers.

geposted Mon 24 Sep 18 @ 2:19 am
I don't know whether this will be of help to anyone, but, I used the Denon drivers successfully for several years and never had a problem with them. I used the Denon MC6000 MK1 for around 4-5 years til it developed too many faults, then I replaced it with the MC6000 MKII in 2016 (I still use it). I did use a boot camped Mac with Windows 7 for around 6 years with the PC version of VirtualDJ then switched to the Mac version of VDJ.

I've just checked and the Denon drivers I have on my W7 system are;

Denon DJ ASIO for DJ Controller ver. 1.0.1. dated 4/12/07
Denon DJ ASIO Driver ver. 2.2.2. dated 1/11/11

I've been using the Mac version of VDJ for 2 or 3 years and don't remember which version of Windows ASIO drivers I was using. I checked the Denon website an hour ago and it doesn't state what version the drivers are that are available for download.

P.S. IIRC my latency was set at 10ms.

geposted Mon 24 Sep 18 @ 8:35 am
jberenyiPRO SubscriberMember since 2015
wickedmix wrote :
the ASIO drivers can be uninstalled if you wont use them but they have nothing to do with my previous comment.

in this image see how the realtek sound card has the green check setting it as default.

if your Denon has that then you could have issues, so set it to the built in sound of the laptop to be default.



Well I tried everything that was offered on this thread. Nothing works. Regretfully I will be returning my deck to PSSL. I have put over 8 hours of trial and error effort to make it work with no positive results. Any deck that is this difficult to make work correctly with VDJ and a laptop is not for me. Time to try Pioneer or give up DJing after 15 years. The new stuff is just too prone to issues. I miss the proven performance of the good ole' days :(

geposted Mon 24 Sep 18 @ 10:54 am
You must set the switch on back of mixer to external (not PC)
Under sound card settings select external mixer
Deck 1 MC6000 wasapi 1+2
Deck 2 MC6000 Wasapi 3+4

You will then have full control

geposted Mon 24 Sep 18 @ 4:02 pm
The Mk2 doesn't have that switch as it's software control only.

geposted Mon 24 Sep 18 @ 4:12 pm
Did not know that, i have 4 of the mk1

geposted Mon 24 Sep 18 @ 9:27 pm
hi guys can any body help i am on the vdj 8 switch from serato dj as having issues . so down loaded the vdj 8 on to my denon mc 6000 mk 2 and the denon mc2000 on the denon mc6000 mk 2 all ok with sound etc .but with the denon mc2000 having trouble with the asio drivers saying no asio sound card .so no sound from controller loads up ok all switches working fine .been back to denon dj and ask them are the asio drivers the same for the both controllers answer yes . but how can one controller work and the other strange . in the audio settings shows up the mc2000 .and in the master and mic outputs .works fine sound with serato dj .have downloaded asio 4 all dosent make any diffrence .
any one had the same issues and fixed the asio drivers sound .

thanks andrew .

geposted Tue 06 Nov 18 @ 3:26 pm