Forum: VirtualDJ Technical Support

For reporting any bug, questions or comment related to the latest version of VirtualDJ
(NOTE: VirtualDJ continuously updated, so many older topic on this forum are most probably already fixed in the current build)

If you need extended support, contact our Support Team.
Forum Guidelines  (*) The moderators hold the rights to move or modify posts in order to keep the discussions clear or to facilitate the search.
Topic: Files Inside Virtual Folder Disappear
I've recently started noticing a problem (i.e. 1-2 weeks ago), whereby clicking on say 'Virtual Folder1' that contains a list of files, will show no files. To be clear, there are no filters on, nothing typed in the search box, no ongoing searches, etc. Clicking on say 'Virtual Folder2' and then clicking 'Virtual Folder1' does not remediate the problem (the thought process being something simply in the view is causing it). The problem is not consistent --- in other words I haven't found a definitive way to trigger it. Further, when it does occur, it affects a single virtual folder --- so not all virtual folders are affected. Also, the same virtual folder isn't affected each time, so it isn't a problem with any one specific virtual folder.

***The problem can be remediated by restarting VDJ, at which point all files will once again show up under 'Virtual Folder1'. This is a bit of pain since during a party, etc., you don't necessarily want to have to restart VDJ to see the Virtual Folder contents.

Sorry, I don't have much more information on the root cause at this point.

geposted Tue 25 Dec 18 @ 6:15 pm
AdionPRO InfinityCTOMember since 2006
Do the files come from multiple drives perhaps?

geposted Tue 25 Dec 18 @ 6:42 pm
Hey Adion, Merry Christmas btw! I'm on a desktop computer. I have a C drive, which runs my primary OS. I have two RAID-1 - 4 TB drives that serve as my D: drive. All of the virtual folders contain music from the D drive and some music from the C drive. When I've observed the issue, I've found the problem to exist with a virtual folder that contains files from only the D drive, and from a virtual folder that contains files from both the C and D drives. (If it helps, I've never had this issue before and been running the same setup for years)

Interesting update, if during the time period where the virtual folder shows blank, I try to add a new file to the folder, upon the next restart, the folder will only have that one file! I checked the corresponding 'vdjfolder' contents and confirmed that it indeed overwrites that file with the one entry. Luckily, I backup the entire VDJ directory often enough, so I just had to restore that one affected file.

Any help would be much appreciated! This is a bit scary!

geposted Wed 26 Dec 18 @ 12:43 am
and here I thought it was my ancient desktop at work having this issue.
current public build does this.
I had the same problem with virtual folders being empty even of files that aren't on the drive that was removed. thumbdrives in this case. the folder would only repopulate when I put the drives back in. drove me a little nuts the first time because I could get zero search results as mentioned above.

geposted Thu 27 Dec 18 @ 8:26 pm
I have the same problem with virtual folders. Has someone got a solution for this problem?

Thanks

geposted Wed 02 Jan 19 @ 10:58 am
Had the same thing happen this past Saturday night, I thought it was something I did but seems it’s an issue with VDJ

geposted Wed 02 Jan 19 @ 4:46 pm
Happened again last night but this time I took a video



They never showed up for the rest of the night either.

geposted Sat 05 Jan 19 @ 2:57 pm
AdionPRO InfinityCTOMember since 2006
Thanks, managed to reproduce and will be fixed in next update.
If it happens to a root virtual folder it will indeed only load again after a restart.
It can happen when loading the virtual folder got interrupted, which could happen during connecting/unplugging an external drive.

geposted Sat 05 Jan 19 @ 4:41 pm
Thanks, Adion. Much appreciated. Sounds like you've isolated the problem. That said, my virtual folders are NOT loaded from external drives, so if your fix only addresses that case, I'm not sure how that would apply here. Either way, I guess we'll wait and see. Thanks again!

geposted Sat 05 Jan 19 @ 5:04 pm
AdionPRO InfinityCTOMember since 2006
No, the fix is not exclusive to external drives, but connecting/disconnecting external drives seems to be the most likely way to trigger the problem.

geposted Sat 05 Jan 19 @ 5:49 pm
Adion wrote :

It can happen when loading the virtual folder got interrupted, which could happen during connecting/unplugging an external drive.


Thats the part that bothers me.

If my drive gets disconnected then usually my tracks disappear and my folder tree resets. My tree never reset or at least I never noticed it.

Is there a way for me to test this out??

And if you noticed in my video it wasn't every virtual folder, it was just a few.

geposted Sat 05 Jan 19 @ 7:13 pm
had exactly that happen last night in the most utterly confusing (and extremely inconvenient time) way when my other dj went to pull his thumbdrive and a folder emptied itself.

I tried different combinations of pulling thumbdrives and it just kept getting weirder til I put a third drive in to load a customer's bday pic in and the folder magically repopulated itself.
so yeah. much confusion.
but we managed. good to know an update on the way tho.

geposted Sun 06 Jan 19 @ 9:33 pm
I have the exact smae problem. Use an external harddrive an dduring a gig som subfolder dissappeared and now when i am grouping some stuff same thing happen. Lose virtual folders and files. Scary.
If i disconnect and connect the external drive problem is solved. But i am a bit scared to do that during a gig.
Also when i close and start VDJ again problem is solved, but i cannot do that during a gig!

geposted Sat 12 Jan 19 @ 10:35 pm
I'm playing on my gig right now and this happened all over again right in this moment.
So I thought I'll post my experiences and discoveries here, in case it helps in some way:

I never use external drives or something similar.
All files in my virtual folders are on the same drive and nothing gets connected or disconnected.
Mostly it happens very randomly to my biggest folder (3179 files)...
This folder is located in the root of my folder-tree.
As mentioned it only can be fixed by restarting Virtual DJ.

I discovered different behaviours for folders located inside other folders:
The problem occurs the same way, but if I close the upper folder and open it again the files will show up again.
So I tried to pack the big folder into another folder and it worked.


Something else I discovered is:

- If the files disappear and I move the affected folder into another one, only the newest files added since a specific date are visible.

- An almost 100% reliable way to reproduce this bug was to change something in my database.
For example adding tracks to a specific folder or cleaning the database through the menu.

- After the tracks disappeared I added one single track to the affected folder to see if the sings appear again... Nothing happened, so I restarted Virtual DJ.
Clicked on the folder and had to see that all files were gone except the one I added during the problem. Thankfully I made a backup because somehow I saw it coming.

I hope it helps identifying the whole structure of the problem.
And I also hope the fixed release comes as fast as possible because this problem drives me crazy.

- Thanks!

geposted Sun 13 Jan 19 @ 1:41 am
Can we get an update on this issue? Thanks in advance!

geposted Sun 20 Jan 19 @ 4:58 pm
AdionPRO InfinityCTOMember since 2006
It's fixed in the current Early Access build 4742

geposted Sun 20 Jan 19 @ 5:02 pm
Great, thanks for the quick reply! Will wait for it to hit final Production release.

geposted Sun 20 Jan 19 @ 5:51 pm
I had a similar problem again with build 4742.
A virtual-folder didn't wanted to open up to show it's subfolders.
I tried to view the files of this folder recursive and this didn't work either.
After a restart everything worked again.

Did anyone experienced the same?

geposted Sat 26 Jan 19 @ 4:21 am
swattyPRO InfinityMember since 2012
I am having issues with Virtual Folders not opening. If I only use a mouse it all works OK. If I open VFs with a controller, navigate to sub folders and then close the top level with a controller button, it will not open again.

I have a ticket in with Tech Support for this but no resolution at present.

geposted Sat 26 Jan 19 @ 1:00 pm
AdionPRO InfinityCTOMember since 2006
There was indeed a related similar issue with showing virtual folder subfolders. A fix will be available soon.

geposted Mon 28 Jan 19 @ 4:54 am