VDJPedia



 Windows - Mac OSX compatibility

Back to FAQ


Q: Is VirtualDJ compatible with my Operating System ?



Please check the following compatibility tables:


Windows
Windows XP (SP3)*
Windows Vista*
Windows 7
Windows 8/8.1
Windows 10


Mac OSX
Leopard (10.5)
Snow Leopard (10.6)
Lion (10.7)**
Mountain Lion (10.8)
Maverick (10.9)
Yosemite (10.10)
El Capitan (10.11)
Sierra (10.12)
High Sierra (10.13)
Mojave (10.14)



* Windows XP / Windows Vista

Windows XP and Windows Vista are only supported up to VirtualDJ 2018 build 4787
You can download it here


** macOS X 10.7

macOS X 10.7 is only supported up to VirtualDJ 2018 build 4918
You can download it here


Please be aware that it is highly recommended to upgrade to a more recent operating system; as these are no longer supported there is a high risk of malware. New controllers, features and updates are also not available for these older builds.

Notes:

  • Some older DJ hardware may not be compatible with the latest available Operating systems. Before upgrading, you should check the manufacturer's websites to ensure that all hardware that you will be using (Sound cards, MIDI controllers, etc.) is compatible.

  • Make sure you have the latest version/build of VirtualDJ http://www.virtualdj.com/download/index.html





Related Topics:
FAQ What are the minimum or recommended system requirements to run VirtualDJ ?
FAQ Can I install VirtualDJ on my Apple iPhone, iPad, iPod or Android?
FAQ Does VirtualDJ work on Linux?



Navigation


Back to FAQ Knowledge Database Wiki HOME