Quick Sign In:  

Forum: VirtualDJ Technical Support

Topic: My own Mapper from my Roland Dj 808 don't work as before
I created the following commands in my mapper for my Roland for the padpage selection buttons.
Example when I press Shift as follows:
This no longer works.
However, if I take out one, either just holding 1000ms? Pad_Menu,
Or just,
Then the command works.
Before it went, but unfortunately I no longer know which update is no longer possible.
What have you screwed up again in the programming?
It will probably not be due to the controller.
Greetings Dani

geposted Sat 28 May 22 @ 11:04 am
AdionPRO InfinityCTOMember since 2006
It looks like your script is missing some spaces:
Holding 1000ms ? PAD_MENU : PAD_PAGE_SELECT

works fine for me

geposted Sat 28 May 22 @ 11:37 am
At the same Controller .... ?
By me no longer works ... :-(
What you mean with Spaces ?

geposted Sat 28 May 22 @ 11:48 am
Space ok....
The command has worked fine before..

geposted Sat 28 May 22 @ 12:01 pm
Why is it?
It must be due to Virtual DJ.
It was working before a couple of updates.
The space between the individual words in the command is correct, that was probably just due to copying and pasting, see screenshot.
Has it been tested on the same controller, Roland DJ-808?
I can't see through it

geposted Wed 01 Jun 22 @ 2:30 pm
djdadPRO InfinityDevelopment ManagerMember since 2005
Indeed the script above will not work for the Roland 808 anymore. There was a conflict in firmware and Split pad pages, and we had to remove the "up" check.

geposted Wed 01 Jun 22 @ 6:17 pm
Than please correct it ,
It has work fine , in early Versions.
No Problems with Firmware or other things.
What are Splitpage ??
I will select the Pages with Shift , this work fine , but the 2. Command , when holding this , don't work .... And when I write only this Command with holding , than the Holding command works good ...
Sorry , I don't understand why should two commands not working at this buttons...
:-( :-( It is then a Program Error Bug , not the Firmware Bug , it has work perfekt before ;-)

geposted Wed 01 Jun 22 @ 6:46 pm
locodogPRO InfinityModeratorMember since 2013
Use doubleclick ? instead.

geposted Wed 01 Jun 22 @ 7:04 pm
But Why dobleklick should work and holding not ??

geposted Wed 01 Jun 22 @ 8:22 pm
locodogPRO InfinityModeratorMember since 2013
djdad wrote :
...we had to remove the "up" check.

that's why. doubleclick doesn't rely on up


geposted Wed 01 Jun 22 @ 8:32 pm
What does up mean ??

geposted Wed 01 Jun 22 @ 8:44 pm
locodogPRO InfinityModeratorMember since 2013
A button has 2 states down & up, it only sends it's state to vdj when it changes.

holding, needs both, down in vdj starts a timer and that checks if it has received an up message within the timer limit, if has received a up then it preforms the press action, if it hasn't then you are holding and it does the holding action.

geposted Wed 01 Jun 22 @ 9:05 pm
mmmhh .. the way I understand it, but I think the button down for .... ms ....
And what I still don't understand was working a few weeks ago, because I don't have the controller as long yet and have only created the mapping well.
No problem with the firmware (latest) ...
Everything was great, now you had failed again
By all other Buttons the holding command works fine

geposted Wed 01 Jun 22 @ 9:17 pm
djdadPRO InfinityDevelopment ManagerMember since 2005
I tried to find the Forums topic where the issue was reported but no luck. Anyways, the issue was introduced when we implemented Split Pad pages https://virtualdj.com/manuals/virtualdj/interface/decks/decksadvanced/pads.html#split
Unfortunately, we had to make a change in Mapping files and the Pad mode buttons (and only these) to avoid Pads get stuck at a page during a certain key combination. So it's not something that was broken in some firmware update, but a bug that was revealed after we added the ability to split/combine Pad pages.

With the change we did, the action assigned to the Pad mode buttons are executed immediately on key press and doesnt wait for the "up" (release) of the button, which makes the actions like holding ? , up ? , down ? , while_pressed etc and Split pad pages not working.


geposted Thu 02 Jun 22 @ 4:56 am
Well, I don't think the Sprit-Padpages option is more important.
I think it's more important that all mappings and commands work without problems, and that it stays that way...
If there are problems with an individual, or only certain controllers, with this split padpage function, then simply remove it for them, deactivate it for the controller.
The number of Padmdus keys is also recognized for each controller, something like that should work then....
I was very happy with the mapping I created and it worked perfectly. Would you like to have it again...

geposted Thu 02 Jun 22 @ 3:43 pm