Forum: General Discussion

About VirtualDJ and DJing in general

If you need extended support, contact our Support Team.
Forum Guidelines  (*) The moderators hold the rights to remove, move or modify posts.
Topic: Versadeck Not Recognized
Since the updates I have lot the ability ro use my American Audio Versa Deck. The New update sees my American Audio MXR10 Mixer even my Hercules Trim 4&6 sound card? But for some strange reason it wont see the Versa Deck as a MIDI? I have 2 of them and I know for a fact they both work. Anyone have a idea to what could be wrong? Thanks for any help. Need to get back in the mix!!!

geposted Tue 23 Jun 20 @ 1:49 am
djdadPRO InfinityDevelopment ManagerMember since 2005
Nothing is changed for Versadeck.
When you say it's not working as MIDI, you dont see the device in Settings->Mappings tab ?
Keep in mind that the Versadeck can work in 2 modes, so perhaps it's on "Mixer mode" where the Mixer is not sending MIDI, but still the Decks/sides work ?
In this case it needs to have Ext Mixer Audio setup (deck 1 , deck 2) and select the "Mixer Mode" mapping

If on "MIDI mode" (where the Mixer sends MIDI and mixing is performed from VDJ mixer), you need to have Master + Headphones in Audio setup and select the "MIDI mode" mapping.

But if you think it's the update, you can go back to an older build https://www.virtualdj.com/download/build.html


EDIT: Regarding switching the Mixer mode, i found this from my notes..
The AA Vesradeck can operate in 2 different modes (Mixer and MIDI). To switch the Versadeck to MIDI mixer mode ..
Switch the device channel A to “Deck A” then you can enter the menu of the Mixer.( Press and hold the “Folder” button)
The switch up until you can see the Menu point “ 5. Mixer Setup”
Change the mixer from “ Mixer” to “ Midi” .
Then go up with the Folder button until you see Exit and Save and store this setting.
You will see “Saving” in the display.


geposted Tue 23 Jun 20 @ 11:38 am
Thanks Djdad for the response. I should have been more clear on my issue. The new software does some what see the Versa Deck. Meaning I have some functionality but in the sound options it does not come up as a sound card option anymore like my MXR10 or Hercules Trim 4&6. I also have no midi control of the volume or EQ or cross fader. also the decks only work on one channel. I have check all my setting on the mixer itself and all are correct. I have 2 versa deck mixers and both do the same thing. It seems like I have map everything like its not supported anymore in VDJ but even if I do I still have the issue of the software not recognizing then versa deck as a sound card like it does my other gear or like it used to in VDJ 7??

geposted Tue 23 Jun 20 @ 7:08 pm
Assuming you're using the 64 bit version of VDJ, does the Versadeck have 64 bit drivers installed?

geposted Tue 23 Jun 20 @ 7:53 pm
Yes grovindj I will try to uninstall and reinstall the drivers

geposted Tue 23 Jun 20 @ 7:56 pm
Djmadman73 wrote :
Yes grovindj I will try to uninstall and reinstall the drivers


EDIT I uninstalled everything and reinstalled drivers. again the mixer lights up when I start VDJ but the versa deck is not a sound card option like it should be.

geposted Tue 23 Jun 20 @ 8:26 pm
....but are the drivers you're installing 64 bit drivers? If you look on their web site, there are separate downloads for 32 bit and 64 drivers.

Make sure you have the right ones.

geposted Tue 23 Jun 20 @ 8:37 pm
groovindj wrote :
....but are the drivers you're installing 64 bit drivers? If you look on their web site, there are separate downloads for 32 bit and 64 drivers.

Make sure you have the right ones.


I have. Now I got it working...for some reason it still doesn't see the Versa Deck as a sound card. In the Option for sound I have to first choice is speakers with headphones. The sound card option where the versa deck should be a option? I have to chose computer? Not using TC So nothing there. Again it's weird that I have to chose this option? I will post a pic of the sound option.

geposted Tue 23 Jun 20 @ 9:42 pm
OK as you can see in the 1st pic I got MXR10 connected and it shows up as a sound card option.



The second pic is with the versa deck connected and you will notice it's not a sound card option and I have to use the computer as sound card to get it to work? Again yes I do have the 64 bit drivers installed


geposted Tue 23 Jun 20 @ 9:57 pm
djdadPRO InfinityDevelopment ManagerMember since 2005
Can you please follow the instructions below and provide the requested data ?
1. Goto Documents/VirtualDJ folder and delete the file named as Log Report.txt (in case it exists)
2. Open VirtualDJ -> goto Settings->OPTIONS tab
3. Search for createMidiLog and set it to Yes
4. Close VDJ, make sure only the Versadeck is connected and powered and open VDJ again
5. Don't have to do/check anything, just close again.
6. Post here the content of the generated Log Report.txt file you will find in Documents/VirtualDJ folder

geposted Wed 24 Jun 20 @ 12:42 am
ok djdad here is the results from the log file

--- 2020/06/23 - 21:14 (5929)
[21:14] math cpu f: avx2 - 1:8 0:8

geposted Wed 24 Jun 20 @ 2:17 am
djdadPRO InfinityDevelopment ManagerMember since 2005
Sure it's just that ?
Can you repeat steps 4 to 6 ?

geposted Wed 24 Jun 20 @ 2:27 am
djdad wrote :
Sure it's just that ?
Can you repeat steps 4 to 6 ?

yeah now i got a lot of data


[21:14] math cpu f: avx2 - 1:8 0:8
--- 2020/06/23 - 22:12 (5929)
[22:12] math cpu f: avx2 - 1:8 0:8
[22:12] math cpu f: avx2 1:8 1:8 1:8+0:8
[22:12] math cpu f: avx2 1:8 1:8 1:8+0:8
[22:12] math cpu f: avx2 1:8 1:8 1:8+0:8
[22:12] math cpu f: avx2 1:8 1:8 1:8+0:8
[22:12] math cpu f: avx2 1:8 1:8 1:8+0:8
[22:12] math cpu b: avx2 1:8 1:8 1:8+0:8
[22:12] math cpu b: avx2 1:8 1:8 1:8+0:8
[22:12] math cpu b: avx2 1:8 1:8 1:8+0:8
[22:12] math cpu b: avx2 1:8 1:8 1:8+0:8
[22:12] math cpu b: avx2 1:8 1:8 1:8+0:8
[22:12] math cpu e: avx2 - 1:8 0:8
[22:12] WASAPI device without vid/pid: Speakers (VERSA DECK WDM Audio 2.9.15) : {2}.\\?\media#aa_versadeck_audioadapter#6&2740c458&3&id01#{6994ad04-93ef-11d0-a3cc-00a0c9223196}\wave
[22:12] WASAPI device without vid/pid: Line In (VERSA DECK WDM Audio 2.9.15) : {2}.\\?\media#aa_versadeck_audioadapter#6&2740c458&3&id01#{6994ad04-93ef-11d0-a3cc-00a0c9223196}\wave
[22:12] Audio device found: name="VERSA DECK WDM Audio 2.9.15" hardwareID:"{0.0.0.00000000}.{19f1e6df-4889-49e5-8478-53636ce66ff4}"
[22:12] Audio device found: name="2- Realtek High Definition Audio" vid="0x10EC" pid="0x0255" hardwareID:"{0.0.0.00000000}.{a68991d3-1a96-46dc-9e99-71dbf1640aa0}"
[22:12] Audio device found: input name="2- Realtek High Definition Audio" vid="0x10EC" pid="0x0255" hardwareID:"{0.0.1.00000000}.{39855944-2eab-4e6e-8456-7a08084789d9}"
[22:12] Audio device found: input name="VERSA DECK WDM Audio 2.9.15" hardwareID:"{0.0.1.00000000}.{5b2eb6d8-8311-4d25-86fa-854fd214945b}"
[22:12] Audio device found: asio="ADJ ASIO" hardwareID:"3BE15936-AE5C-48A3-B87BE3CAA70013B9"
[22:12] Audio device found: asio="VERSA DECK USB ASIO driver" hardwareID:"8E6D2E7C-2806-44B7-8FE0B0CA3E5BB45D"
[22:12] WASAPI device without vid/pid: Speakers (VERSA DECK WDM Audio 2.9.15) : {2}.\\?\media#aa_versadeck_audioadapter#6&2740c458&3&id01#{6994ad04-93ef-11d0-a3cc-00a0c9223196}\wave
[22:12] WASAPI device without vid/pid: Line In (VERSA DECK WDM Audio 2.9.15) : {2}.\\?\media#aa_versadeck_audioadapter#6&2740c458&3&id01#{6994ad04-93ef-11d0-a3cc-00a0c9223196}\wave
[22:12] Midi out device detected, name:Microsoft GS Wavetable Synth mid:1 pid:27
[22:12] MIDI Device Identifying: \\?\usb#vid_200c&pid_100d&mi_04#6&2740c458&3&id01#{6994ad04-93ef-11d0-a3cc-00a0c9223196}\aa_versadeck_midi (in:0 out:1) (name: VERSA DECK MIDI)
[22:12] MIDI Device Identified by PID/VID: \\?\usb#vid_200c&pid_100d&mi_04#6&2740c458&3&id01#{6994ad04-93ef-11d0-a3cc-00a0c9223196}\aa_versadeck_midi : American Audio VersaDeck Midi Mode
[22:12] Assigned Keyboard, type:0, index:1
[22:12] MIDI Device Identifying: Microsoft GS Wavetable Synth (in:-1 out:0) (name: Microsoft GS Wavetable Synth)
[22:12] Midi Out Closed (Microsoft GS Wavetable Synth)
[22:12] MIDI Device Not Identified: Microsoft GS Wavetable Synth
[22:12] HID Device found: VID:0x04F3 PID:0x3019 path:\\?\hid#elan0501&col03#5&1d53633d&0&0002#{4d1e55b2-f16f-11cf-88cb-001111000030}
[22:12] Assigned Keyboard, type:0, index:1
[22:12] WASAPI device without vid/pid: Speakers (VERSA DECK WDM Audio 2.9.15) : {2}.\\?\media#aa_versadeck_audioadapter#6&2740c458&3&id01#{6994ad04-93ef-11d0-a3cc-00a0c9223196}\wave
[22:12] WASAPI device without vid/pid: Line In (VERSA DECK WDM Audio 2.9.15) : {2}.\\?\media#aa_versadeck_audioadapter#6&2740c458&3&id01#{6994ad04-93ef-11d0-a3cc-00a0c9223196}\wave
[22:12] Midi In Closed (\\?\usb#vid_200c&pid_100d&mi_04#6&2740c458&3&id01#{6994ad04-93ef-11d0-a3cc-00a0c9223196}\aa_versadeck_midi)
[22:12] Midi Out Closed (\\?\usb#vid_200c&pid_100d&mi_04#6&2740c458&3&id01#{6994ad04-93ef-11d0-a3cc-00a0c9223196}\aa_versadeck_midi)


geposted Wed 24 Jun 20 @ 3:15 am
djdadPRO InfinityDevelopment ManagerMember since 2005
Thanks, will be in touch with u soon

geposted Wed 24 Jun 20 @ 4:07 am
Just to chime in, i am a versadeck user as well. and i finally upgraded to windows 10 just because of vdj 2021. steps that worked for me

plug in versadeck first, see if its recognized by windows
then run the asio 64 drivers
then restart
then open VDJ after restart. it should give u the splash screen saying versadeck detected.
if not close and change the usb port

in windows 7 i was never able to connect the versadeck to the usb 3 port, it only worked on the 2 port. but in win 10 with the same laptop it works on both ports now.


geposted Sun 28 Jun 20 @ 3:40 pm
djdadPRO InfinityDevelopment ManagerMember since 2005
The OP didnt have a detection issue. He is just missing the special button in Audio setup of VirtualDJ settings, and he needs to manually create and apply.

Do you have that ?
On which mode is your Versadeck, Mixer or MIDI ?

geposted Sun 28 Jun 20 @ 4:30 pm
The versa deck is in midi but I did everything that was previously suggested. Again it works for me and is coming up as detected by VDJ It's just not coming up as a sound card option like it used to

geposted Tue 30 Jun 20 @ 10:37 pm